How to fix Netbook restart issue with Linux (Ubuntu)

Linux OS Topics

How to fix Netbook restart issue with Linux (Ubuntu)

Postby Saman » Sat Jan 14, 2012 9:40 pm

I installed Ubuntu 11.10 on my newly bought Acer Aspire One D257 netbook. Though it came with Windows 7 Starter I couldn't live without Linux  :)

However there was a strange restart issue. Netbook never restarted and ended up in a black screen unlike on the Windows starter installation. However Power Off worked perfectly. After making several attems I was able to fix it and though it would be helpful to share this information with you.

The reason for these issues could be a BIOS issue or the hardware setup of the system. For example some netbooks with Atom processor doesn't come with a keyboard controller in which case Linux kernel can't figure out the way to tackle that situation. However the best thing about Linux is, there is always a solution if you can sit in-front of for many hours  :D

  1. Type following command,
    Code: Select all
    $ sudo nano /etc/default/grub


  2. Find GRUB_CMDLINE_LINUX=”” and change it to GRUB_CMDLINE_LINUX=”reboot=efi”

  3. Press Ctrl-O to save and then Ctrl-X to exit

  4. Type following command to update the grub
    Code: Select all
    $ sudo update-grub

Power off your machine and then Switch it on again. Once it is booted, try to restart it to see whether it is working. If this is not working, try following commands instead of efi (i.e.: reboot=efi).

  1. warm =  Don’t set the cold reboot flag
  2. cold = Set the cold reboot flag
  3. bios = Reboot by jumping through the BIOS (only for X86_32)
  4. smp = Reboot by executing reset on BSP or other CPU (only for X86_32)
  5. triple = Force a triple fault (init)
  6. kbd = Use the keyboard controller. cold reset (default)
  7. acpi = Use the RESET_REG in the FADT
  8. efi = Use efi reset_system runtime service
  9. pci = Use the so-called “PCI reset register”, CF9
  10. force = Avoid anything that could hang.

According to the feedbacks I received, bios, acpi, pci, efi seems to be probable solutions.

Acer Aspire One D257 netbook - efi fixed the issue
Acer Aspire One Happy 2 netbook - acpi fixed the issue
Dell latitude E6420 - pci fixed the issue
Please add what worked for you to this list.
User avatar
Saman
Support Team
Support Team
 
Posts: 816
Joined: Fri Jul 31, 2009 5:02 pm
Cash on hand: 152,553.20
Location: Mount Lavinia
Medals: 1
EC_Achievment (1)

Invitations sent: 44
Registered friends: 1
Reputation point: 37
Staff Sergeant

Return to Linux Center

Who is online

Users browsing this forum: No registered users and 0 guests